OpenWRT.su

Open.Wireless.Super and LEDE

Сборки OpenWrt 18.06.2 для TP-Link MR3020 V1

Сборки OpenWrt 18.06.2 для TP-Link MR3020 V1

OpenWrt предлагает уже отказаться от устройств с 4 мб дисковой и 32 мб оперативной памяти и забыть их как страшный сон. Но как мы знаем - они еще могут принести пользу, несмотря на скромные возможности. Устройства очень популярны до сих пор, но официальный репозитарий текущей ветки не предоставляет предварительно собранные версии прошивки для версии железа V1, поэтому быть может кому-то окажутся полезными мои сборки OpenWrt 18.06.2 для TP-Link MR3020 V1. Архивы для скачки c .config файлами сборки и более подробная информация ниже.

1. Cборка OpenWrt 18.06.2 для TP-Link MR3020 V1 стандарт

Ничего не вырезано, конфигурационные файлы стандартные. Вшита Luci, после установки 92кб свободной дисковой памяти. Расширить память не получится, для тех кому хватает стандартной начинки. 

Скачать файл mr3020v1-v180602-basic.zip (7mb) (MD5 Hash: e2701c1780c2699ed40b61a9d4a661f3)
Уже скачали 129 раз

2. Cборка OpenWrt 18.06.2 для TP-Link MR3020 V1 без поддержки IPv6

Вырезана поддержка  IPv6 на этапе сборки по данной инструкции. Вшита Luci, после прошивки устройства у вас будет доступно 288кб свободной дисковой памяти. Места для каких-то пакетов может и хватит, расширить память на флешку также как и в предыдущей сборке не получится, так как слишком много нынче весят модули поддержки файловых систем для ядра. 

Скачать файл mr3020v1-v180602-noIPv6.zip (7mb) (MD5 Hash: 732b41bd5bde0d63db41663fca2493d4)
Уже скачали 122 разa

3. Cборка OpenWrt 18.06.2 для TP-Link MR3020 V1 без поддержки IPv6, с пакетами для расширения дисковой памяти на usb-флешку 

Вырезана поддержка IPv6 на этапе сборки. Вшиты Luci, kmod-usb-storage, kmod-fs-f2fs, block mount. Набор для расширения дисковой памяти на usb-флешку c файловой системой F2fs. После установки прошивки у вас будет 96 кб свободного места для приведения конфигов к нужному виду. 

Скачать файл mr3020v1-v180602-exoverlay-noIPv6.zip (7mb) (MD5 Hash: 06b7c186b96b036e1b34b44205255519)
Уже скачали 157 раз

4. Cборка OpenWrt 18.06.2 для TP-Link MR3020 V1 Без Luci, без поддержки IPv6, с пакетами для расширения дисковой памяти на usb-флешку

Для тех кому не нужна веб-морда и они могут все делать через uci и ssh. Вшиты kmod-usb-storage, kmod-fs-f2fs, block mount. Свободного места после прошивки 356 кб. 

Скачать файл mr3020v1-v180602-noLuci-noIPv6-exoverlay.zip (7mb) (MD5 Hash: 3ad143b7fb7e3a4039672cff4a8d50f9)
Уже скачали 123 разa

Каждый архив содержит, как *factory, так и *sysupgrade образ, также .config файл кросс-компилятора.

Комментарии  

werter
-2 # werter 28.03.2019 16:19
>>Cборка OpenWrt 18.06.2 для TP-Link MR3020 V1 без поддержки IPv6

CONFIG_DEFAULT_ip6tables=y
CONFIG_DEFAULT_odhcp6c=y
CONFIG_DEFAULT_odhcpd-ipv6only=y
Аяяй :)

>>CONFIG_TARGET_SQUASHFS_BLOCK_SIZE=256
Для уменьшения размера фирмвари рекомендую 1024

P.s. Если нужны прошивки максимально избавленные от IPv6, то вот, собранные мною 4pda.ru/forum/index.php?showtopic=911457
Скачать OpenWrt/LEDE -> Прошивки собранные пользователями
Ответить | Ответить с цитатой | Цитировать
Wrtman
-1 # Wrtman 28.03.2019 18:54
Спасибо за оперативное дополнение) пересоберу
Ответить | Ответить с цитатой | Цитировать
Linux_Addict
-1 # Linux_Addict 29.03.2019 11:46
Если в глобалках отключено на остальное похер, не парь
Ответить | Ответить с цитатой | Цитировать
Славик
0 # Славик 27.05.2019 22:56
Большое спасибо за Ваши старания.Не могли бы вы подсказать при попытке поставить пакет openvpn ssl пишет что поставит не может из за несоответствия ядра.подскажите как это можно исправить
Ответить | Ответить с цитатой | Цитировать
Славик
0 # Славик 27.05.2019 23:00
Забыл добавить сборка первая из этой статьи у роутера увеличен там до 62 и ром до 8мб
Ответить | Ответить с цитатой | Цитировать
Lem
0 # Lem 05.09.2019 02:01
root@OpenWrt:~# opkg install kmod-usb-net-cdc-ether
Installing kmod-usb-net-cdc-ether (4.9.152-1) to root...
Downloading downloads.openwrt.org/releases/18.06.2/targets/ar71xx/tiny/packages/kmod-usb-net-cdc-ether_4.9.152-1_mips_24kc.ipk
Collected errors:
* satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-net-cdc-ether:
* kernel (= 4.9.152-1-590acf3fecb4e0e9d01b08c7632cb375)
* opkg_install_cmd: Cannot install package kmod-usb-net-cdc-ether.
Ответить | Ответить с цитатой | Цитировать
salexa
0 # salexa 19.09.2019 15:04
Цитирую Lem:
...
Cannot satisfy the following dependencies for kmod-usb-net-cdc-ether:
* kernel (= 4.9.152-1-590acf3fecb4e0e9d01b08c7632cb375)
* opkg_install_cmd: Cannot install package kmod-usb-net-cdc-ether.
Замените в вашей сборке в файле /usr/lib/opkg/status хэш метапакета kernel на хэш из официального рпозитория, откуда пытаетесь ставить модули ядра:Цитата:
Package: kernel
Version: 4.9.152-1-590acf3fecb4e0e9d01b08c7632cb375
...
Ответить | Ответить с цитатой | Цитировать
xnsp
+1 # xnsp 15.11.2019 21:17
How compile MR3020 image ?
The MR3020 is not in ImageBuilder.

How add MR3020-V1 in image builder ?

Thank's
Ответить | Ответить с цитатой | Цитировать
nile perch
0 # nile perch 04.12.2019 03:39
hello thanks so much - i need OpenWrt build 18.06.2 for TP-Link MR3020 V1 with 3G + 4G + EVDO brodband can you help me - i have evdo cu860
Ответить | Ответить с цитатой | Цитировать
Александр
0 # Александр 10.05.2020 23:24
А как удалось создать прошивку 18 версии, если официально последняя 17?
Ответить | Ответить с цитатой | Цитировать
Wrtman
0 # Wrtman 11.05.2020 21:01
последняя 19
Ответить | Ответить с цитатой | Цитировать
Александр
0 # Александр 13.05.2020 00:04
официальная на TP-Link MR3020 V1
Ответить | Ответить с цитатой | Цитировать
Wrtman
0 # Wrtman 13.05.2020 09:56
можно собрать самому что я исделал
Ответить | Ответить с цитатой | Цитировать
Кирилл
0 # Кирилл 08.06.2020 12:36
Можно даже самую последнюю версию. Но нужно собирать из исходников. Это не есть сложно.
Ответить | Ответить с цитатой | Цитировать
Closed
0 # Closed 21.06.2020 22:21
После установки прошивки репы стали практически бесполезны. При установке mc или nano, хочет библиотеку libc, но не находит ее. Библиотеки glibc тоже нет. Да на них половина репа завязана.
Ответить | Ответить с цитатой | Цитировать
Кирилл
0 # Кирилл 21.06.2020 22:56
Их можно собрать как отдельные пакеты, а потом установить на роутере: пакеты находятся в папке packages, собери все, которые нужны, скопируй их все на роутер, в определенную папку (куда удобно,я создаю для этих целей директорию в tmp) копировал, а потом всё устанавливаю: cd /tmp/folder opkg install *.ipk и всё, что ему нужно,он поставит, главное, что бы места хватило...
Ответить | Ответить с цитатой | Цитировать
diakudza
0 # diakudza 05.08.2020 19:47
Цитирую Closed:
После установки прошивки репы стали практически бесполезны. При установке mc или nano, хочет библиотеку libc, но не находит ее. Библиотеки glibc тоже нет. Да на них половина репа завязана.


пакет то есть в репах. downloads.openwrt.org/releases/18.06.2/targets/ar71xx/tiny/packages/libc_1.1.19-1_mips_24kc.ipk Но мне уже не помещается
Ответить | Ответить с цитатой | Цитировать
diakudza
0 # diakudza 05.08.2020 19:46
скачал сборку №4 , но там не получается флешку на ext4 примонтировать. Поставил пакет kmod-fs-ext4, в fstab указал все, но mount и block mount не цепляют ее.

root@OpenWrt:~# dmesg | grep ext4
[ 9.498312] ext4: Unknown symbol posix_acl_chmod (err 0)

понял, что нет пакета acl. нашел, он маленький, но тянет 3 библиотеки. одна из них (libc) весит 271кб. Которых после установки поддержи ext4 уже нет.

Мучаюсь уже несколько дней, ни как не могу систему на флешку перенести. Может кто знает, как можно выкрутиться?
Ответить | Ответить с цитатой | Цитировать
jyan
0 # jyan 27.08.2020 12:07
У меня флеш на 16мб может у вас будет время собрать 19 версию OPenWRT для mr3020 v1? Спасибо
Ответить | Ответить с цитатой | Цитировать
Кирилл
0 # Кирилл 27.08.2020 12:10
Подскажите, как собрать версию прошивки на 8 мб, я я собирал, у меня получилось 3,6 мб
Ответить | Ответить с цитатой | Цитировать
jyan
0 # jyan 31.08.2020 01:50
Что-то не получается собрать для версии 1 с перепаянной флеш на 16мб. Яна вашей прошивки не смог завести hilink модем никак. Какие только пакеты ни ставил и что только ни придумывал. На 17 прошивке все работает как часы, но мне нужна именно 18 или выше. Может будет время собрать 19 или хотя бы 18 но последний релиз. Спаибо!
Ответить | Ответить с цитатой | Цитировать

Добавить комментарий

Если вы хотите получать сообщения c ответами на ваши комментарии - то укажите свой настоящий e-mail. Если же вы тут проездом, чтобы оставить комментарий укажите в поле email no@openwrt.su